Sabtu, 10 November 2018

Bandwidth Management Mikrotik Menggunakan Simple Queue

Banyaknya tool atau setting yang berada pada mikrotik kadangkala justru akan membuat bingung bagi admin jaringan itu sendiri (pengalaman pribadi), karena admin tersebut belum mengetahui dengan pasti apa sebenarnya setting yang paling sesuai untuk diterapkan pada kondisi jaringannya.

Disini saya akan berbagi settingan yang menurut saya sangat cocok untuk diterapkan di tempat yang memiliki dinamik user seperti di sekolah, kampus, balai pelatihan, yang notabene internet digunakan untuk kebutuhan belajar bukan untuk kebutuhan multimedia seperti streaming mapun download 

keunggulan dari settingan ini sebenarnya adalah Limited Download dan Youtube tetapi Unlimited Browsing, berikut settingannya, sesuaikan dengan topologi jaringan masing-masing



/ip firewall layer7-protocol
add name=L7-Youtube regexp=youtube.com|googlevideo.com

/ip firewall mangle
add action=mark-connection chain=prerouting comment=all_download_conn \
    connection-bytes=1000000-0 connection-rate=200k-100M new-connection-mark=\
    All_Download passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment=all-download-pk \
    connection-mark=All_Download new-packet-mark=All_Download passthrough=no
add action=mark-packet chain=forward comment=youtube layer7-protocol=\
    L7-Youtube new-packet-mark=Youtube-Packet

/queue simple
add max-limit=4M/4M name=Youtube packet-marks=Youtube-Packet queue=\
    default/default target="192.168.5.0/24"
add max-limit=8M/8M name=Download packet-marks=All_Download queue=\
    default/default target="192.168.5.0/24"


Hasilnya






Default target silahkan sesuai dengan jaringan masing-masing, disini kami menggunakan ip 192.168.5.0/24

Keterangan : Jika trafik memiliki koneksi pertama lebih dari 1MB dan masih membutuhkan speed diatas 200kbps, maka trafik ini akan kita anggap (di tandai dengan mark connection) sebagai trafik Download dan akan terlimit di simple queue dengan max download 8Mbps

Kenapa di IDM cuma terdetect 1MBps?

Karena di IDM menggunakan MBps (mega bytes per second) sedangkan di winbox setting menngunakan Mbps (mega bits persecond), Ingat 1MB=8Mb